View Issue Details

IDProjectCategoryView StatusLast Update
0000040Gorilla3D[All Projects] Feature Requestpublic2019-11-06 13:35
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.8.1.x 
Target Version0.8.1.xFixed in Version0.8.1.x 
Summary0000040: Create an optimized TTextLayer3D alternative
DescriptionOn android devices the architecture of layers is very unperformant. Because layers creating "screenshots" on modification, this is getting heavy on mobile devices. A simple TextLayer3D do not need a buffer update each time, only when text changes. Therefore we need a fast alternative to FMX component.
TagsNo tags attached.
Delphi-Version
OpenGLVersionOpenGL 4.6

Activities

administrator

2019-11-06 13:35

administrator   ~0000028

TGorillaTextLayer3D implemented and working much better on android devices.

Issue History

Date Modified Username Field Change
2019-11-06 13:34 administrator New Issue
2019-11-06 13:34 administrator Status new => assigned
2019-11-06 13:34 administrator Assigned To => administrator
2019-11-06 13:35 administrator Status assigned => resolved
2019-11-06 13:35 administrator Resolution open => fixed
2019-11-06 13:35 administrator Fixed in Version => 0.8.1.x
2019-11-06 13:35 administrator Note Added: 0000028