View Issue Details

IDProjectCategoryView StatusLast Update
0000032Gorilla3D[All Projects] Bug Reportspublic2019-11-06 09:34
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version0.8.1.x 
Target Version0.8.1.xFixed in Version0.8.1.x 
Summary0000032: RenderPass method is not implemented correctly
DescriptionIn next release TRenderPassMethod will support 4 methods for precise distinction: RenderlistToContext, RenderListToFBO, RectToContext and RectToFBO.
In previous version the "ToContext" did not allow to render a rect shader to render pass FBO. Everything was written to default context FBO.
Therefor concatination of renderpasses was not possible.
TagsNo tags attached.
Delphi-Version
OpenGLVersion

Activities

administrator

2019-11-06 09:34

administrator   ~0000023

TRenderPassMethod type was changed to:
TRenderPassMethod = (RenderListToContext, RenderListToFBO, RectToContext, RectToFBO);

RenderListToContext - will render all objects in renderlist with the provided render pass material. The output will be written to the default context FBO.
It doesn't matter if you declare and attach an individual FBO in your renderpass, because it will be ignored.

RenderListToFBO - will render all objects in renderlist with the provided render pass material. The output will be written to the FBO of your renderpass.

RectToContext - will render on basis of the latest context FBO or on a attached renderpass output. The output will be written to the default context FBO.
It doesn't matter if you declare and attach an individual FBO in your renderpass, because it will be ignored.

RectToFBO - will render on basis of the latest context FBO or on a attached renderpass output. The output will be written to the FBO of your renderpass.

Issue History

Date Modified Username Field Change
2019-10-05 21:42 administrator New Issue
2019-10-05 21:42 administrator Status new => assigned
2019-10-05 21:42 administrator Assigned To => administrator
2019-11-06 09:34 administrator Status assigned => resolved
2019-11-06 09:34 administrator Resolution open => fixed
2019-11-06 09:34 administrator Fixed in Version => 0.8.1.x
2019-11-06 09:34 administrator Note Added: 0000023