View Issue Details

IDProjectCategoryView StatusLast Update
0000243Gorilla3D[All Projects] Bug Reportspublic2023-11-09 16:24
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeverityblockReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version1.2 
Target Version1.2Fixed in Version1.1 
Summary0000243: Bug: Sketchfab Plugin not downloading in v12.0 (400 Bad Request)
DescriptionIn Delphi 12.0 Athens we're receiving a "400 Bad Request" response on downloading assests from AWS by Sketchfab Plugin. It's working fine until 11.3.
Additional Information---------------------------
Benachrichtigung ├╝ber Debugger-Exception
---------------------------
Im Projekt SketchfabClient.x64.exe ist eine Exception der Klasse ERequestError mit der Meldung '<?xml version="1.0" encoding="UTF-8"?>
<Error><Code>InvalidToken</Code><Message>The provided token is malformed or otherwise invalid.</Message><Token-0>IQoJb3JpZ2luX2VjEJb%2F%2F%2F%2F%2F%2F%2F%2F%2F%2FwEaCWV1LXdlc3QtMSJHMEUCIQC1RiPIWp88q%2FyViFHSVSP6juP5dXugjWTneF63gx4vDAIgA0YmG7gxlktxk6eGBu1kgebZuThwwG1ZKFL15bnp3dQquwUIz%2F%2F%2F%2F%2F%2F%2F%2F%2F%2F%2FARAAGgw2Nzg4NzQzNzE4OTIiDJN9MyurKYOdvJfU%2ByqPBQmAwj%2BzCQj7kbggWKnkoiEosp0oCSj%2BaHL4E155P1boNczozVhqdQMcXEWOK7FcARyNZLL5ntzjOdxDZmDV1zjW%2F5ProXhmMheTd7f13ItwpLYAStZe5hznyMJZmUJbU%2BjEf7xnILNZn531u61PXwDkJudQ4G9gPpeWes5qky8mEmzd6xLHJjvqxk0q%2BKNjkbcRdlE0TYOt9V0fW9qdk3dzQ%2F3Y6xPTBCVOZw%2FnwF8yTrTCFk3OmdKR0f0ks6AnogOrhfwxJulVjKqBLHc2dUdxZcEI3Etm0i1Uv3NVsbc%2BJu6xvFkl4d5%2F6wEMY6dqEttSKWHJ4k4pJJShiFq64FM%2Fyq1W35mwH7rTxVGLaykCkzUQDlg3kGtED4RA5oz1FcCSN7GTFp6phoH3wkAAFuO7K4xP1jp6VFjo%2Ft8nPpLwD7%2BUsmzV%2FmpK42MmrhZmiPbJk51EarEDECdkKq2aAynoBxgw99Ybsg5nmBXKxIxkQjIfbw1%2BnqvSlfTNA4v9mXvkpm2r6w02NmJisgXsNWpIfOGUwYe70fhZG83Xjt5D66V7k8FZJ%2BgfDLRyuJZQgwewO%2BPiZT3OS7ZHHD7pp1cbsKcSxZctzGGe9gQdTpV9o8PZ4BPfbrXLRTWvrYt1OEx6mZJ0LcKvVjbJ7oAXsaB%2BLgDZRxA6smtTB60zmxWaTMYVjfudBzVWY9EUDCThooFha1cMQNA%2BeqApAIGhwCPbz4i6%2BdA8EAsdWmcMGJKpFfaGvg%2F%2BNWpkVzKfChhgdfgRVhqi%2FYFPrBm%2BFFY%2Bm8QliigaFw7SO86PKU7QCAbi65zdUM83rp8o%2BTB5qGpiKS8jX%2FxOg%2B2iq1Cib9VkNY1TW5dbQ8WRqwYDTr8DKicwmOmxqgY6sQFStsngL0PfzmVAU0KYxglTa325iobItDg8yNJ0oXVw9vhVD5j6%2BkApTq8Irggx6xq4XpqW%2BKp05g79usdqm7PiotRUkgcjEu1LDtNKfbcdojwoHTVZc9N%2FvbUjEfVtJ%2FdXJoPcTPwoV1SzCqQ5hG6v91pQdyfK27kqU3EqzgtbuwfKV7YwNeFyEKr298iq1I5bWkySaZDj8SITAGekAZKd4Zb2KCKqnHVOY50bNBAmSOY%3D</Token-0><RequestId>CJC50KTBACRN8M9M</RequestId><HostId>VDz0ZOUou6edQOsYYvLQUUDDgvfpOttSQXNHZCaosbIIQGN0jVfmAOsMuDrWodk9EMvD2QMzExs=</HostId></Error>' aufgetreten.
---------------------------
Anhalten Fortsetzen Kopieren Hilfe
---------------------------
TagsNo tags attached.
Delphi-Version 12.0.0
OpenGLVersionOpenGL 4.3

Activities

administrator

2023-11-09 16:24

administrator   ~0000272

Fixed in Rev. 2821
Download Url for AWS got encoded again due to different THttpClient behaviour in 12.0.
Implemented a new helper class to solve this issue.

Issue History

Date Modified Username Field Change
2023-11-09 08:34 administrator New Issue
2023-11-09 08:34 administrator Status new => assigned
2023-11-09 08:34 administrator Assigned To => administrator
2023-11-09 08:35 administrator Additional Information Updated View Revisions
2023-11-09 16:24 administrator Status assigned => resolved
2023-11-09 16:24 administrator Resolution open => fixed
2023-11-09 16:24 administrator Fixed in Version => 1.1
2023-11-09 16:24 administrator Note Added: 0000272