View Issue Details

IDProjectCategoryView StatusLast Update
0000160Gorilla3D[All Projects] Bug Reportspublic2021-11-11 14:35
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version0.8.3.x 
Target Version0.8.3.xFixed in Version0.8.3.x 
Summary0000160: Bug: [Android] textures not loaded or cleared on loading [v0.8.3.1843]
DescriptionTextures in DefaultMaterials are not loaded correctly or cleared on loading up.
The problem only occurs on Android platform!
TagsNo tags attached.
Delphi-Version 10.4.2
OpenGLVersionOpenGL 4.3

Activities

administrator

2021-04-23 11:31

administrator   ~0000175

Protected texture variables were removed, because it's difficult to keep them updated during designtime usage.
Now all texture properties read directly from BitmapPool.

This makes the code much easier and stable, but a bit slower.
Sadly this is not the final solution.

administrator

2021-11-11 14:35

administrator   ~0000202

Fixed in rev.2076

TPixelFormatExHelper.CompatibleFormat() introduced to detect the correc corresponding basis format, if component format is incompatible
The error occured on loading textures from DFM files.
Because we store "InternalFormat" / "Format" in DFM files, to restore the correct texture format after loading, "RGBA8" + "BGRA" was loaded on Android
This led to incompatible texture format settings and ended in a black textures.
We now detect incompatible formats and try to fix them on the fly. There is no better solution since TBitmap supports all formats.

Issue History

Date Modified Username Field Change
2021-04-17 14:13 administrator New Issue
2021-04-17 14:13 administrator Status new => assigned
2021-04-17 14:13 administrator Assigned To => administrator
2021-04-23 11:31 administrator Note Added: 0000175
2021-11-11 14:35 administrator Status assigned => resolved
2021-11-11 14:35 administrator Resolution open => fixed
2021-11-11 14:35 administrator Fixed in Version => 0.8.3.x
2021-11-11 14:35 administrator Note Added: 0000202