View Issue Details

IDProjectCategoryView StatusLast Update
0000136Gorilla3D[All Projects] Bug Reportspublic2021-02-08 08:48
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeveritytweakReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version0.8.3.x 
Target Version0.8.3.xFixed in Version0.8.3.x 
Summary0000136: Viewport resize at designtime not updating content
DescriptionIDE do not updates viewport correctly.
Maybe due to render optimizations a redrawn is not executed at design time
Steps To ReproduceI had a Viewport on the form and some buttons around.
When double-click on form's caption to maximize the Window the Viewport "wrongly" resize the content.
Some buttons was "overdrawn" by viewport.
[...]
Maximizing is not "same" like resize via drag-drop.
TagsNo tags attached.
Delphi-Version 10.4.1
OpenGLVersionOpenGL 4.3

Activities

administrator

2021-01-22 12:08

administrator   ~0000146

UPDATE: The maximize / restore problem is not in design time problem. Happens also at runtime.

administrator

2021-01-26 10:20

administrator   ~0000149

On resizing a TRenderer no invalidate was called, so the rendered image stays as it was.
I've implemented an Invalidate() call on resize to force re-rendering.
In some cases it didn't occurred, because an animation was played back or a TTimer with Invalidate already existed

administrator

2021-02-08 08:47

administrator   ~0000151

Further changes are documented in another task

administrator

2021-02-08 08:48

administrator   ~0000152

Correct color order bugfix implemented. New package needs to be built.

Issue History

Date Modified Username Field Change
2021-01-22 09:36 administrator New Issue
2021-01-22 09:36 administrator Status new => assigned
2021-01-22 09:36 administrator Assigned To => administrator
2021-01-22 09:37 administrator Description Updated View Revisions
2021-01-22 12:08 administrator Note Added: 0000146
2021-01-26 10:20 administrator Status assigned => confirmed
2021-01-26 10:20 administrator Note Added: 0000149
2021-02-08 08:47 administrator Note Added: 0000151
2021-02-08 08:48 administrator Status confirmed => resolved
2021-02-08 08:48 administrator Resolution open => fixed
2021-02-08 08:48 administrator Fixed in Version => 0.8.3.x
2021-02-08 08:48 administrator Note Added: 0000152