View Issue Details

IDProjectCategoryView StatusLast Update
0000107Gorilla3D[All Projects] Feature Requestpublic2020-10-11 11:17
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeverityfeatureReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version0.8.3.x 
Target Version0.8.3.xFixed in Version0.8.3.x 
Summary0000107: Async particles computation
DescriptionWhen using a particle emitter with a large amount of particles, performance getting bad very fast, because in complex scenes everything is rendered in main thread. We have to provide a property "Async" to allow asynchronous computation for particles.
This has to be optional, because for low-level particle emitters the overhead is too much.
TagsNo tags attached.
Delphi-Version 10.4.1
OpenGLVersionOpenGL 4.3

Activities

administrator

2020-10-11 11:17

administrator   ~0000111

A new property "Async" is now available in particle emitters, which enables background thread computation of particles.
Use this property in case you have many particles to be manipulated. So mainthread will no longer be bothered with those operations. For emitters with a few particles (less than ~ 250) the overhead comsuming advantages due to synchronization with render pipeline.

Issue History

Date Modified Username Field Change
2020-10-08 07:51 administrator New Issue
2020-10-08 07:51 administrator Status new => assigned
2020-10-08 07:51 administrator Assigned To => administrator
2020-10-11 11:17 administrator Status assigned => resolved
2020-10-11 11:17 administrator Resolution open => fixed
2020-10-11 11:17 administrator Fixed in Version => 0.8.3.x
2020-10-11 11:17 administrator Note Added: 0000111