View Issue Details

IDProjectCategoryView StatusLast Update
0000089Gorilla3D[All Projects] Bug Reportspublic2020-05-18 09:30
ReporteradministratorAssigned Toadministrator 
PriorityimmediateSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.8.2.x 
Target Version0.8.2.xFixed in Version0.8.2.x 
Summary0000089: RayCastIntersect on TGorillaModel / TGorillaMesh not working properly without BVH
DescriptionThe slow default raycast intersection test not working properly for TGorillaModel / TGorillaMesh without BVH method.
Raycast was not dispatched to submeshes, therefore hittest was not successful.
Besides that the triangle test also failed in most cases due to wrong triangle normal computation.
TagsNo tags attached.
Delphi-Version 10.3.3
OpenGLVersionOpenGL 4.3

Activities

administrator

2020-05-18 09:30

administrator   ~0000077

fixed

Issue History

Date Modified Username Field Change
2020-05-18 09:30 administrator New Issue
2020-05-18 09:30 administrator Status new => assigned
2020-05-18 09:30 administrator Assigned To => administrator
2020-05-18 09:30 administrator Status assigned => resolved
2020-05-18 09:30 administrator Resolution open => fixed
2020-05-18 09:30 administrator Fixed in Version => 0.8.2.x
2020-05-18 09:30 administrator Note Added: 0000077