View Issue Details

IDProjectCategoryView StatusLast Update
0000003Gorilla3D[All Projects] Releasespublic2020-03-14 15:55
ReporteradministratorAssigned Toadministrator 
PriorityurgentSeveritymajorReproducibilityhave not tried
Status closedResolutionfixed 
Product Version0.7.1.950 (alpha) 
Target Version0.7.1.950 (alpha)Fixed in Version0.7.1.950 (alpha) 
Summary0000003: Release 0.7.1.950 (alpha)
DescriptionHello and welcome to the alpha release phase of Gorilla3D framework for Delphi 10.1.1+ Firemonkey.

You can download your software package at:
Delphi Berlin 10.1.1: https://diggets.com/files/packages/Gorilla3D-Delphi-10.1.1-Berlin-0.7.1.950.zip
Delphi Berlin 10.2.3: https://diggets.com/files/packages/Gorilla3D-Delphi-10.2.3-Tokyo-0.7.1.950.zip

How to install:
1) Download the zip-archive and unpack
2) In Delphi IDE go to: Menu > Components > Install packages
3) Select the "Gorilla3D_Delphi_10_1_1_Berlin.bpl" from your destination directory
4) To insert DCU's go to: Menu > Tools > Options > Environmentoptions > Delphi-Options > Library > Library-Path
(repeat this for every platform: win32, win64 and android)

For your information:
A class documentation can be found at: https://doc.diggets.com/

FreeTools-Download:
1) AssetsManager (managing packages with models, textures and more):
https://diggets.com/files/tools/Gorilla3D-AssetsManager-1.0.0.0.zip

2) DialogueDesigner (create complex dialogues and store them as *.dia file to load at runtime):
https://diggets.com/files/tools/Gorilla3D-DialogueDesigner-1.0.0.0.zip

3) InventoryDesigner (create complex inventory systems and store them as *.iff to load at runtime):
https://diggets.com/files/tools/Gorilla3D-InventoryDesigner-1.0.0.0.zip

4) ShaderDesigner (writer shaders and test them immediatly, store them as *.g3ds to load at runtime):
https://diggets.com/files/tools/Gorilla3D-ShaderDesigner-1.0.1.5.zip


Remarks:
This package is marked as "developer-edition", which can only be used for developing purposes! It is not allowed to distribute the package or any software build with this package.
For distribution in future separate editions will be offered.
Additional InformationTerms & Conditions
Both the Licensee and Software provider agree to adhere to the following terms and conditions.

The Software Provider has granted, with acceptance of this source code license agreement, Manaz GmbH total licenses to be used as permitted. These licenses shall be considered perpetual and non-transferrable.

The licenses granted may be used by the Licensee as well as any employees and subcontractors providing services for the Licensee.

Throughout this agreement, “Software” shall be defined as all source codes, object codes, link libraries, utility programs, project files, scripts related to the software listed above.

The Software shall remain the intellectual property of the Software Provider at all times.

License Grant
In consideration of all terms and conditions contained within this contract the Licensee shall have the nonexclusive and nontransferable rights as stated below.

The Licensee will hold the right to incorporate the dynamic and statically linked libraries that the Software Provider has developed.

Restrictions
Unless prior written consent has been obtained from the Software Owner, the following shall not be allowed.

The Licensee is not allowed to make and distribute an unlimited number of copies of the libraries mentioned above.

The distribution of any source codes, header files, make files, or libraries of the software.
The software should not be merged, compiled, or copied unless expressed in this agreement.
Alteration or removal of any notices in or on the software or within the documentation included within the software.
Any distribution of the software by the Licensee that is not conducted with approval from the Software Provider.
Disclosure of any source codes pertaining to the software to any additional parties not included in this agreement.
The Licensee shall not disassemble, decompile or reverse engineer any object code contained within the software.
The number of licenses being used may at no point and time be more than the number of licenses purchased through this agreement.

Warranties
All software included in this source code license agreement as well as all documentation included with said software is provided in an “as is” condition.

The Licensee shall be granted a 72 hour period after initial access is granted. During this period, the Licensee may report any errors, missing features, or other issues related to the source code.

This initial inspection shall be performed with the source code in its original state. Any modification or other alteration of the source code shall constitute acceptance of the Software by the Licensee.

The Software Provider agrees to correct any such errors in a timely manner, after which the Licensee shall accept the source code for use pursuant to the terms of this agreement.

The Software Provider makes no guarantee as to the source code’s performance once it has been accepted by the Licensee.

Liability
Under no circumstances will either party or their representatives be liable to each other for any incidental, consequential, or indirect damages including but not limited to lost or damaged data, revenue loss, economic loss, or commercial loss arising out of a breach of any terms and conditions set forth in this source code license agreement.

This limitation of liability shall apply regardless of if the alleged breach is a fundamental breach or fundamental term.

Both parties are in understanding that some jurisdictions do not allow the exclusion of liability for consequential damages and as so the above limitation may not apply.

Term & Termination
While the term of this agreement may be perpetual, this agreement may terminate immediately in the event any breach occurs of the terms and conditions listed herein.

The defaulting party will be allotted 30 days to cure the breach upon written notice or face immediate agreement termination.

Under no condition should any disclosures of the licensed source code or theft of the Clients computers be grounds for termination of this agreement.

In the event of termination the Licensee must destroy any and all copies of the Software as well as the included documentation.

Indemnity
The Licensee agrees to hold the Software Provider harmless as well as defend the Software Provider from any and all damages, costs, and liabilities that take place from a lawsuit due to any of the following

Product Distribution
Breach of Contract
Software installation
Additionally, the Software Provider shall indemnify and hold the Licensee harmless against any damages related to the source code.

Copyright Notice
The Licensee agrees to display an appropriate copyright notice in any final versions of Software containing the source code distributed to third parties.

Applicable law
Any disputes related to this agreement shall be resolved in accordance with the laws of Manaz GmbH, Bielefeld, NRW, Germany and any and all legal proceedings shall take place as such.
TagsNo tags attached.
Delphi-Version
OpenGLVersion

Activities

administrator

2020-03-14 15:55

administrator   ~0000059

released

Issue History

Date Modified Username Field Change
2018-07-20 09:46 administrator New Issue
2018-07-20 09:46 administrator Status new => assigned
2018-07-20 09:46 administrator Assigned To => administrator
2018-08-01 14:41 administrator Description Updated View Revisions
2018-08-01 15:09 administrator Description Updated View Revisions
2018-08-01 16:02 administrator Description Updated View Revisions
2018-08-01 16:15 administrator Additional Information Updated View Revisions
2018-08-01 16:21 administrator Description Updated View Revisions
2018-08-03 13:52 administrator Description Updated View Revisions
2018-08-12 15:04 administrator Description Updated View Revisions
2019-04-13 21:34 emanuel Issue cloned: 0000008
2020-03-14 15:55 administrator Status assigned => closed
2020-03-14 15:55 administrator Resolution open => fixed
2020-03-14 15:55 administrator Fixed in Version => 0.7.1.950 (alpha)
2020-03-14 15:55 administrator Note Added: 0000059