View Issue Details

IDProjectCategoryView StatusLast Update
0000158Gorilla3D[All Projects] Bug Reportspublic2021-04-16 12:05
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionfixed 
Product Version0.8.3.x 
Target Version0.8.3.xFixed in Version0.8.3.x 
Summary0000158: Volume Rendering Demo not clearing background correctly in v0.8.3.1840
DescriptionVolume Rendering not clearing background and getting brighter on each rendering
Check for changes made since last package compilation
TagsNo tags attached.
Delphi-Version 10.4.2
OpenGLVersionOpenGL 4.3

Activities

administrator

2021-04-15 14:55

administrator   ~0000172

Changes on TFrameBufferObject.Clear(), due to fixes on resizing problem with Bokeh effect, lead to side-effects in Volume-Rendering.
The render-target clearing seems to be a little bit difficult to handle in complex context.

administrator

2021-04-16 12:05

administrator   ~0000173

fixed in 0.8.3.1843
CurrentRenderer was not cleared on resize -> invalid renderer causing problems

Issue History

Date Modified Username Field Change
2021-04-15 10:47 administrator New Issue
2021-04-15 10:47 administrator Status new => assigned
2021-04-15 10:47 administrator Assigned To => administrator
2021-04-15 10:48 administrator Summary Volume Rendering not clearing background => Volume Rendering Demo not clearing background
2021-04-15 14:55 administrator Note Added: 0000172
2021-04-15 14:56 administrator Summary Volume Rendering Demo not clearing background => Volume Rendering Demo not clearing background correctly in v0.8.3.1840
2021-04-16 12:05 administrator Status assigned => resolved
2021-04-16 12:05 administrator Resolution open => fixed
2021-04-16 12:05 administrator Fixed in Version => 0.8.3.x
2021-04-16 12:05 administrator Note Added: 0000173