View Issue Details

IDProjectCategoryView StatusLast Update
0000155Gorilla3D[All Projects] Bug Reportspublic2021-11-24 08:18
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version0.8.4.x 
Target Version0.8.4.xFixed in Version0.8.3.x 
Summary0000155: BUGFIX: Deleting an linked MaterialSource at designtime leads to exceptions
DescriptionWhen deleting a linked MaterialSource component at designtime leads to an exception in the linked component during rendering, because the reference was not automatically removed by IDE.

Check the usage of "Observers" here.
TagsNo tags attached.
Delphi-Version
OpenGLVersionOpenGL 4.3

Activities

administrator

2021-11-24 08:18

administrator   ~0000203

Fixed.
We've implemented the Notification() method inside of all components to release references at designtime

Issue History

Date Modified Username Field Change
2021-04-11 12:53 administrator New Issue
2021-04-11 12:53 administrator Status new => assigned
2021-04-11 12:53 administrator Assigned To => administrator
2021-10-29 08:58 administrator Summary Bug: Deleting an linked MaterialSource at designtime leads to exceptions => BUGFIX: Deleting an linked MaterialSource at designtime leads to exceptions
2021-10-29 08:58 administrator Delphi-Version 10.4.2 =>
2021-11-24 08:18 administrator Status assigned => resolved
2021-11-24 08:18 administrator Resolution open => fixed
2021-11-24 08:18 administrator Fixed in Version => 0.8.3.x
2021-11-24 08:18 administrator Note Added: 0000203