View Issue Details

IDProjectCategoryView StatusLast Update
0000011Gorilla3D[All Projects] Feature Requestpublic2019-09-17 08:10
ReporteradministratorAssigned Toadministrator 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version0.8.0.2000 
Target Version0.8.0.2000Fixed in Version0.8.0.2000 
Summary0000011: Sphere Terrain Component
DescriptionA customer wishes to have a sphere terrain component like TGorillaTerrain but for a spherical mesh.
TagsNo tags attached.
Delphi-Version
OpenGLVersion

Activities

administrator

2019-09-17 08:03

administrator   ~0000013

Implemented a new component Gorilla.Terrain.Sphere.TGorillaSphereTerrain. It supports generation from heightmap and random algorithm (Diamond Square, Hill, ...) generation like regular terrain.
Using a random algorithm may cause gaps, because no sphere heightmap texture will be created. Pixel value on left, may be different from pixel value on right.
So I recommend to heightmap generation from spherical height maps.

Issue History

Date Modified Username Field Change
2019-09-16 06:57 administrator New Issue
2019-09-16 06:57 administrator Status new => assigned
2019-09-16 06:57 administrator Assigned To => administrator
2019-09-17 08:02 administrator Status assigned => resolved
2019-09-17 08:02 administrator Resolution open => fixed
2019-09-17 08:03 administrator Note Added: 0000013
2019-09-17 08:10 administrator Fixed in Version => 0.8.0.2000